Website outage
Incident Report for Catalyst
Resolved
Service has been restored.
Posted 5 months ago. Jun 04, 2019 - 17:45 EDT
Monitoring
Service has been restored and we're continuing to monitor the site.
Posted 5 months ago. Jun 04, 2019 - 17:11 EDT
Investigating
Service to our website has been interrupted. We are investigating the issue and will report updates here as soon as they're available.
Posted 5 months ago. Jun 04, 2019 - 17:06 EDT
This incident affected: Website.